Installing & Configuration

Requirements
Your website need to match the following minimal requirements:

  • PHP 7.2 or higher.
  • Joomla! 3.8 or higher.

Installation
Install the plugin like any other Joomla package.

  1. Navigate to the administrator side of your website.
  2. Go to Extensions > Manage > Install and drag the downloaded package onto the installer.
  3. SD Icons is now installed. You should see a splash screen.

Configuration
Configuring SD Icons is easy! Follow the steps:

  1. Navigate to the administrator side of your website.
  2. Go to Extensions > Plugins.
  3. Use the search to search for SD Icons.
  4. Open the plugin and configure the options described below to your liking!

Options
SD Icons currently supports FontAwesome and LineAwesome.

Option Explanation Default
Run At Select where the plugin should be active. Site
FontAwesome Enable this option to enable FontAwesome tags. No
Include FontAwesome If your websites does not yet have FontAwesome included, your can include it by enabling this option. No
Kit URL If you'd like to use the Pro icons of FontAwesome, you'll need a FontAwesome kit. Set one up here. Leave it empty to use the Free version.
LineAwesome Enable this option to enable LineAwesome tags. No
Include LineAwesome If your website does not yet have LineAwesome included, you can include it by enabling this option. No