Installing & Configuring

Requirements
Your website needs to match the following minimal requirements:

  • PHP 7.2 or higher with zLib enabled.
  • Joomla! 3.8 or higher.
  • MySQL 5.7 or MariaDB 10 or higher.

Installation
Install the plugin like any other Joomla package.

  • Navigate to the administrator side of your website.
  • Go to Extensions > Manage > Install and drag the downloaded package onto the installer.
  • SD PackageUpload is now installed. You should see a splash screen.

First-time use
You need to set up an authentication key before you can start uploading packages to your website. For safety measures, we highly recommend whitelisting IP addresses too.

  1. Navigate to the administrator side of your website.
  2. Go to Global Settings > SD PackageUpload.
  3. Enter a random and unique, non-guessable, authentication key. Get a random one from Random Keygen, for example.
  4. Whitelist any IP's that may upload. This is not required, but highly recommended!